Build Record

Build Number: 7968

Transaction: 3984
Package: brave
Version: 0.20.46dev-1
Start: 05/10/2018 04:02PM
Finish: 05/10/2018 04:06PM
Result: failed

Build Log

  1 [05/10/2018 04:02PM]: [\^/\^/^\^/^\^/\^/\^/^\^/^\^/]  SETTING UP ENVIRONMENT  [\^/\^/^\^/^\^/\^/\^/^\^/^\^/]
  2  [05/10/2018 04:02PM]: [\^/\^/^\^/^\^/\^/\^/^\^/^\^/]  ADDING UPSTREAM PGP KEYS TO KEYRING  [\^/\^/^\^/^\^/\^/\^/^\^/^\^/]
  3  [05/10/2018 04:02PM]: gpg: WARNING: unsafe ownership on homedir /tmp/antbs/.gnupg
  4  [05/10/2018 04:02PM]: gpg: keybox /tmp/antbs/.gnupg/pubring.kbx created
  5  [05/10/2018 04:02PM]: gpg: key 23EFEFE93C4CFFFE: 1 signature not checked due to a missing key
  6  [05/10/2018 04:02PM]: gpg: /tmp/antbs/.gnupg/trustdb.gpg: trustdb created
  7  [05/10/2018 04:02PM]: gpg: key 23EFEFE93C4CFFFE: public key Italo A. Casas <[email protected]> imported
  8  [05/10/2018 04:02PM]: gpg: key B63B535A4C206CA9: 8 signatures not checked due to missing keys
  9  [05/10/2018 04:02PM]: gpg: key B63B535A4C206CA9: public key Evan Lucas <[email protected]> imported
 10  [05/10/2018 04:02PM]: gpg: key E73BC641CC11F4C8: 14 signatures not checked due to missing keys
 11  [05/10/2018 04:02PM]: gpg: key E73BC641CC11F4C8: public key Myles Borins <[email protected]> imported
 12  [05/10/2018 04:02PM]: gpg: key C273792F7D83545D: 2 signatures not checked due to missing keys
 13  [05/10/2018 04:02PM]: gpg: key C273792F7D83545D: public key Rod Vagg <[email protected]> imported
 14  [05/10/2018 04:02PM]: gpg: key C97EC7A07EDE3FC1: 19 signatures not checked due to missing keys
 15  [05/10/2018 04:02PM]: gpg: key C97EC7A07EDE3FC1: public key keybase.io/jasnell <[email protected]> imported
 16  [05/10/2018 04:02PM]: gpg: key 09FE44734EB7990E: public key Jeremiah Senkpiel <[email protected]> imported
 17  [05/10/2018 04:02PM]: gpg: key 7434390BDBE9B9C5: public key Colin Ihrig <[email protected]> imported
 18  [05/10/2018 04:02PM]: gpg: key 61B7B526D98F0353: 26 signatures not checked due to missing keys
 19  [05/10/2018 04:02PM]: gpg: key 61B7B526D98F0353: public key Mozilla Software Releases <[email protected]> imported
 20  [05/10/2018 04:02PM]: gpg: key 61B7B526D98F0353: Mozilla Software Releases <[email protected]> not changed
 21  [05/10/2018 04:02PM]: gpg: no ultimately trusted keys found
 22  [05/10/2018 04:02PM]: gpg: Total number processed: 9
 23  [05/10/2018 04:02PM]: gpg:               imported: 8
 24  [05/10/2018 04:02PM]: gpg:              unchanged: 1
 25  [05/10/2018 04:02PM]: [\^/\^/^\^/^\^/\^/\^/^\^/^\^/]  SYNCING REPO DATABASES  [\^/\^/^\^/^\^/\^/\^/^\^/^\^/]
 26  [05/10/2018 04:02PM]: :: Synchronizing package databases...
 27  [05/10/2018 04:02PM]: downloading antergos-staging.db...
 28  [05/10/2018 04:02PM]: downloading antergos.db...
 29  [05/10/2018 04:02PM]: downloading core.db...
 30  [05/10/2018 04:02PM]: downloading community.db...
 31  [05/10/2018 04:02PM]: :: Starting full system upgrade...
 32  [05/10/2018 04:02PM]: looking for conflicting packages...
 33  [05/10/2018 04:02PM]: Packages (75) archlinux-keyring-20180404-1  bash-4.4.019-1  binutils-2.30-4  bzip2-1.0.6-7  ca-certificates-mozilla-3.36.1-1  cryptsetup-2.0.3-1  curl-7.59.0-2  dbus-1.12.8-1  device-mapper-2.02.177-5  dhcpcd-7.0.4-1  e2fsprogs-1.44.1-1  expect-5.45.4-1  file-5.33-1  filesystem-2018.1-2  gawk-4.2.1-1  gc-7.6.4-1  gcc-8.1.0-1  gcc-libs-8.1.0-1  git-2.17.0-1  glib2-2.56.1-1  glibc-2.27-3  gnupg-2.2.6-1  gnutls-3.5.18-1  gpgme-1.11.1-1  iana-etc-20180221-1  iproute2-4.16.0-1  iptables-1.6.2-2  less-530-1  libatomic_ops-7.6.4-1  libcap-ng-0.7.9-1  libgpg-error-1.31-1  libidn-1.34-2  libldap-2.4.46-1  libnghttp2-1.31.1-1  libnsl-1.2.0-1  libpsl-0.20.2-1  libsecret-0.18.6-1  libsystemd-238.76-1  libtirpc-1.0.3-2  libtool-2.4.6+40+g6ca5e224-6  libunistring-0.9.9-1  libusb-1.0.22-1  libutil-linux-2.32-3  linux-api-headers-4.16.1-1  logrotate-3.14.0-1  lz4-1:1.8.1.2-1  mercurial-4.5.3-1  mpfr-4.0.1-1  nano-2.9.6-1  ncurses-6.1-3  openssh-7.7p1-1  openssl-1.1.0.h-1  p11-kit-0.23.10-1  pacman-5.0.2-3  pacman-mirrorlist-20180415-1  pam-1.3.0-2  patch-2.7.6-1  pcre-8.42-1  pcre2-10.31-1  perl-5.26.2-1  perl-mailtools-2.20-1  perl-timedate-2.30-4  pinentry-1.1.0-3  python-3.6.5-2  python2-2.7.15-1  reflector-2018-1  sed-4.5-1  sqlite-3.23.1-1  systemd-238.76-1  systemd-sysvcompat-238.76-1  tcl-8.6.8-3  tzdata-2018e-1  util-linux-2.32-3  wget-1.19.5-1  xz-5.2.4-1
 34  [05/10/2018 04:02PM]: Total Download Size:   102.64 MiB
 35  [05/10/2018 04:02PM]: Total Installed Size:  789.20 MiB
 36  [05/10/2018 04:02PM]: Net Upgrade Size:       28.36 MiB
 37  [05/10/2018 04:02PM]: :: Proceed with installation? [Y/n]
 38  [05/10/2018 04:02PM]: downloading gcc-libs-8.1.0-1-x86_64.pkg.tar.xz...
 39  [05/10/2018 04:02PM]: downloading perl-5.26.2-1-x86_64.pkg.tar.xz...
 40  [05/10/2018 04:02PM]: downloading file-5.33-1-x86_64.pkg.tar.xz...
 41  [05/10/2018 04:02PM]: downloading pacman-5.0.2-3-x86_64.pkg.tar.xz...
 42  [05/10/2018 04:02PM]: downloading systemd-sysvcompat-238.76-1-x86_64.pkg.tar.xz...
 43  [05/10/2018 04:02PM]: downloading perl-mailtools-2.20-1-any.pkg.tar.xz...
 44  [05/10/2018 04:02PM]: downloading python-3.6.5-2-x86_64.pkg.tar.xz...
 45  [05/10/2018 04:02PM]: checking package integrity...
 46  [05/10/2018 04:02PM]: checking for file conflicts...
 47  [05/10/2018 04:02PM]: :: Processing package changes...
 48  [05/10/2018 04:02PM]: upgrading archlinux-keyring...
 49  [05/10/2018 04:02PM]: ==> Appending keys from archlinux.gpg...
 50  [05/10/2018 04:02PM]: ==> Locally signing trusted keys in keyring...
 51  [05/10/2018 04:02PM]:   -> Locally signing key DDB867B92AA789C165EEFA799B729B06A680C281...
 52  [05/10/2018 04:02PM]:   -> Locally signing key 684148BB25B49E986A4944C55184252D824B18E8...
 53  [05/10/2018 04:02PM]:   -> Locally signing key 91FFE0700E80619CEB73235CA88E23E377514E00...
 54  [05/10/2018 04:02PM]:   -> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7...
 55  [05/10/2018 04:02PM]:   -> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...
 56  [05/10/2018 04:02PM]: ==> Importing owner trust values...
 57  [05/10/2018 04:02PM]: ==> Disabling revoked keys in keyring...
 58  [05/10/2018 04:02PM]:   -> Disabling key 7FA647CD89891DEDC060287BB9113D1ED21E1A55...
 59  [05/10/2018 04:02PM]:   -> Disabling key D4DE5ABDE2A7287644EAC7E36D1A9E70E19DAA50...
 60  [05/10/2018 04:02PM]:   -> Disabling key 40440DC037C05620984379A6761FAD69BA06C6A9...
 61  [05/10/2018 04:02PM]:   -> Disabling key B1F2C889CB2CCB2ADA36D963097D629E437520BD...
 62  [05/10/2018 04:02PM]:   -> Disabling key BC1FBE4D2826A0B51E47ED62E2539214C6C11350...
 63  [05/10/2018 04:02PM]:   -> Disabling key 63F395DE2D6398BBE458F281F2DBB4931985A992...
 64  [05/10/2018 04:02PM]:   -> Disabling key 8F76BEEA0289F9E1D3E229C05F946DED983D4366...
 65  [05/10/2018 04:02PM]:   -> Disabling key 4FCF887689C41B09506BE8D5F3E1D5C5D30DB0AD...
 66  [05/10/2018 04:02PM]:   -> Disabling key 81D7F8241DB38BC759C80FCE3A726C6170E80477...
 67  [05/10/2018 04:02PM]:   -> Disabling key 5E7585ADFF106BFFBBA319DC654B877A0864983E...
 68  [05/10/2018 04:02PM]:   -> Disabling key E7210A59715F6940CF9A4E36A001876699AD6E84...
 69  [05/10/2018 04:02PM]:   -> Disabling key F5A361A3A13554B85E57DDDAAF7EF7873CFD4BB6...
 70  [05/10/2018 04:02PM]:   -> Disabling key 8CF934E339CAD8ABF342E822E711306E3C4F88BC...
 71  [05/10/2018 04:02PM]:   -> Disabling key 5696C003B0854206450C8E5BE613C09CB4440678...
 72  [05/10/2018 04:02PM]:   -> Disabling key 9515D8A8EAB88E49BB65EDBCE6B456CAF15447D5...
 73  [05/10/2018 04:02PM]:   -> Disabling key 4A8B17E20B88ACA61860009B5CED81B7C2E5C0D2...
 74  [05/10/2018 04:02PM]:   -> Disabling key 0B20CA1931F5DA3A70D0F8D2EA6836E1AB441196...
 75  [05/10/2018 04:02PM]:   -> Disabling key 34C5D94FE7E7913E86DC427E7FB1A3800C84C0A5...
 76  [05/10/2018 04:02PM]:   -> Disabling key 39F880E50E49A4D11341E8F939E4F17F295AFBF4...
 77  [05/10/2018 04:02PM]:   -> Disabling key 66BD74A036D522F51DD70A3C7F2A16726521E06D...
 78  [05/10/2018 04:02PM]:   -> Disabling key DBE7D3DD8C81D58D0A13D0E76BC26A17B9B7018A...
 79  [05/10/2018 04:02PM]:   -> Disabling key 07DFD3A0BC213FA12EDC217559B3122E2FA915EC...
 80  [05/10/2018 04:02PM]:   -> Disabling key 44D4A033AC140143927397D47EFD567D4C7EA887...
 81  [05/10/2018 04:02PM]:   -> Disabling key 27FFC4769E19F096D41D9265A04F9397CDFD6BB0...
 82  [05/10/2018 04:02PM]:   -> Disabling key 8840BD07FC24CB7CE394A07CCF7037A4F27FB7DA...
 83  [05/10/2018 04:02PM]: ==> Updating trust database...
 84  [05/10/2018 04:02PM]: gpg: marginals needed: 3  completes needed: 1  trust model: pgp
 85  [05/10/2018 04:02PM]: gpg: depth: 0  valid:   1  signed:   8  trust: 0-, 0q, 0n, 0m, 0f, 1u
 86  [05/10/2018 04:02PM]: gpg: depth: 1  valid:   8  signed:  74  trust: 0-, 0q, 0n, 8m, 0f, 0u
 87  [05/10/2018 04:02PM]: gpg: depth: 2  valid:  74  signed:   8  trust: 74-, 0q, 0n, 0m, 0f, 0u
 88  [05/10/2018 04:02PM]: gpg: next trustdb check due at 2018-06-25
 89  [05/10/2018 04:02PM]: upgrading linux-api-headers...
 90  [05/10/2018 04:02PM]: warning: /etc/locale.gen installed as /etc/locale.gen.pacnew
 91  [05/10/2018 04:02PM]: upgrading ca-certificates-mozilla...
 92  [05/10/2018 04:03PM]: installing perl-mailtools...
 93  [05/10/2018 04:03PM]: New optional dependencies for glib2
 94  [05/10/2018 04:03PM]:     python: gdbus-codegen, glib-genmarshal, glib-mkenums, gtester-report [installed]
 95  [05/10/2018 04:03PM]: New optional dependencies for gnupg
 96  [05/10/2018 04:03PM]: upgrading pacman-mirrorlist...
 97  [05/10/2018 04:03PM]: warning: /etc/pacman.d/mirrorlist installed as /etc/pacman.d/mirrorlist.pacnew
 98  [05/10/2018 04:03PM]: warning: directory permissions differ on /var/cache/pacman/
 99  [05/10/2018 04:03PM]: filesystem: 777  package: 755
100  [05/10/2018 04:03PM]: upgrading systemd-sysvcompat...
101  [05/10/2018 04:03PM]: :: Running post-transaction hooks...
102  [05/10/2018 04:03PM]: ( 1/11) Warn about old perl modules
103  [05/10/2018 04:03PM]: ( 2/11) Updating journal message catalog...
104  [05/10/2018 04:03PM]: ( 3/11) Reloading system manager configuration...
105  [05/10/2018 04:03PM]:   Skipped: Current root is not booted.
106  [05/10/2018 04:03PM]: ( 4/11) Updating udev hardware database...
107  [05/10/2018 04:03PM]: ( 5/11) Applying kernel sysctl settings...
108  [05/10/2018 04:03PM]: ( 6/11) Creating system user accounts...
109  [05/10/2018 04:03PM]: ( 7/11) Creating temporary files...
110  [05/10/2018 04:03PM]:   Skipped: Device manager is not running.
111  [05/10/2018 04:03PM]: ( 9/11) Arming ConditionNeedsUpdate...
112  [05/10/2018 04:03PM]: (10/11) Updating the info directory file...
113  [05/10/2018 04:03PM]: (11/11) Rebuilding certificate stores...
114  [05/10/2018 04:03PM]: [\^/\^/^\^/^\^/\^/\^/^\^/^\^/]  TRYING BUILD  [\^/\^/^\^/^\^/\^/\^/^\^/^\^/]
115  [05/10/2018 04:03PM]: [\^/\^/^\^/^\^/\^/\^/^\^/^\^/]  UPDATING SOURCE CHECKSUMS  [\^/\^/^\^/^\^/\^/\^/^\^/^\^/]
116  [05/10/2018 04:03PM]: ==> Generating checksums for source files...
117  [05/10/2018 04:03PM]: ==> Making package: brave 0.19.88dev-1 (Thu May 10 21:03:20 UTC 2018)
118  [05/10/2018 04:03PM]: ==> Checking runtime dependencies...
119  [05/10/2018 04:03PM]: ==> Installing missing dependencies...
120  [05/10/2018 04:03PM]: :: There are 9 providers available for ttf-font:
121  [05/10/2018 04:03PM]:    1) ttf-google-fonts-typewolf
122  [05/10/2018 04:03PM]:    2) noto-fonts  3) ttf-bitstream-vera  4) ttf-croscore  5) ttf-dejavu  6) ttf-freefont
123  [05/10/2018 04:03PM]:    7) ttf-droid  8) ttf-liberation  9) ttf-ubuntu-font-family
124  [05/10/2018 04:03PM]: Enter a number (default=1):
125  [05/10/2018 04:03PM]: warning: dependency cycle detected:
126  [05/10/2018 04:03PM]: warning: harfbuzz will be installed before its freetype2 dependency
127  [05/10/2018 04:03PM]: Packages (61) atk-2.28.1-1  avahi-0.7+4+gd8d8c67-1  cairo-1.15.12-1  dbus-glib-0.110-1  fontconfig-2.13.0+10+g58f5285-1  freetype2-2.9.1-1  fribidi-1.0.2-1  gdk-pixbuf2-2.36.12-1  graphite-1:1.3.11-1  gtk-update-icon-cache-3.22.30-1  harfbuzz-1.7.6-2  hicolor-icon-theme-0.17-1  icu-61.1-1  jasper-2.0.14-1  js52-52.7.3-2  libcroco-0.6.12+4+g9ad7287-1  libcups-2.2.7-2  libdaemon-0.14-3  libdatrie-0.2.10-2  libfontenc-1.1.3-1  libjpeg-turbo-1.5.3-1  libpng-1.6.34-2  librsvg-2:2.42.4-1  libthai-0.1.27-1  libtiff-4.0.9-1  libx11-1.6.5-1  libxau-1.0.8-3  libxcb-1.13-1  libxcomposite-0.4.4-2  libxcursor-1.1.15-1  libxdamage-1.1.4-3  libxdmcp-1.1.2-1  libxext-1.3.3-1  libxfixes-5.0.3-2  libxft-2.3.2-1  libxi-1.7.9-1  libxinerama-1.1.3-2  libxml2-2.9.8-2  libxrandr-1.5.1-2  libxrender-0.9.10-1  lzo-2.10-1  nspr-4.19-1  pango-1.42.1-1  pixman-0.34.0-1  polkit-0.114-1  shared-mime-info-1.9-1  xcb-proto-1.13-1  xorg-fonts-encodings-1.0.4-4  xorg-mkfontdir-1.0.7-8  xorg-mkfontscale-1.1.3-1  xorgproto-2018.4-1  alsa-lib-1.1.6-1  desktop-file-utils-0.23+4+g92af410-1  gconf-3.2.6+11+g07808097-3  gtk2-2.24.32-1  libgnome-keyring-3.12.0-2  libnotify-0.7.7-1  libxss-1.2.2-2  libxtst-1.2.3-1  nss-3.36.1-1  ttf-google-fonts-typewolf-17.11.git+2e2caa2-1
128  [05/10/2018 04:03PM]: Total Download Size:     1.03 MiB
129  [05/10/2018 04:03PM]: Total Installed Size:  347.05 MiB
130  [05/10/2018 04:03PM]: downloading libxinerama-1.1.3-2-x86_64.pkg.tar.xz...
131  [05/10/2018 04:03PM]: downloading dbus-glib-0.110-1-x86_64.pkg.tar.xz...
132  [05/10/2018 04:03PM]: downloading gconf-3.2.6+11+g07808097-3-x86_64.pkg.tar.xz...
133  [05/10/2018 04:03PM]: downloading libxtst-1.2.3-1-x86_64.pkg.tar.xz...
134  [05/10/2018 04:03PM]: Optional dependencies for harfbuzz
135  [05/10/2018 04:03PM]:     cairo: hb-view program [pending]
136  [05/10/2018 04:03PM]: warning: directory permissions differ on /var/
137  [05/10/2018 04:03PM]:   Fontconfig configuration is done via /etc/fonts/conf.avail and conf.d.
138  [05/10/2018 04:03PM]:   Read /etc/fonts/conf.d/README for more information.
139  [05/10/2018 04:03PM]:   Configuration via /etc/fonts/local.conf is still possible,
140  [05/10/2018 04:03PM]:   but is no longer recommended for options available in conf.avail.
141  [05/10/2018 04:03PM]:   Main systemwide configuration should be done by symlinks
142  [05/10/2018 04:03PM]:   (especially for autohinting, sub-pixel and lcdfilter):
143  [05/10/2018 04:03PM]:   ln -s ../conf.avail/XX-foo.conf
144  [05/10/2018 04:03PM]:   Check also https://wiki.archlinux.org/index.php/Font_Configuration
145  [05/10/2018 04:03PM]:   and https://wiki.archlinux.org/index.php/Fonts.
146  [05/10/2018 04:03PM]: Rebuilding fontconfig cache... done.
147  [05/10/2018 04:03PM]: Optional dependencies for libxcursor
148  [05/10/2018 04:03PM]:     gnome-themes-standard: fallback icon theme
149  [05/10/2018 04:03PM]: installing shared-mime-info...
150  [05/10/2018 04:03PM]: Optional dependencies for libtiff
151  [05/10/2018 04:03PM]:     freeglut: for using tiffgt
152  [05/10/2018 04:03PM]: Optional dependencies for avahi
153  [05/10/2018 04:03PM]:     gtk3: avahi-discover, avahi-discover-standalone, bshell, bssh, bvnc
154  [05/10/2018 04:03PM]:     gtk2: gtk2 bindings [pending]
155  [05/10/2018 04:03PM]:     pygtk: avahi-bookmarks
156  [05/10/2018 04:03PM]:     python2-twisted: avahi-bookmarks
157  [05/10/2018 04:03PM]:     nss-mdns: NSS support for mDNS
158  [05/10/2018 04:03PM]:     python-gobject: avahi-discover
159  [05/10/2018 04:03PM]:     python-dbus: avahi-discover
160  [05/10/2018 04:03PM]: Optional dependencies for jasper
161  [05/10/2018 04:03PM]:     jasper-doc: documentation
162  [05/10/2018 04:03PM]: installing hicolor-icon-theme...
163  [05/10/2018 04:03PM]: installing gtk-update-icon-cache...
164  [05/10/2018 04:03PM]: installing desktop-file-utils...
165  [05/10/2018 04:03PM]: Optional dependencies for gtk2
166  [05/10/2018 04:03PM]:     gnome-themes-standard: Default widget theme
167  [05/10/2018 04:03PM]:     adwaita-icon-theme: Default icon theme
168  [05/10/2018 04:03PM]: Optional dependencies for alsa-lib
169  [05/10/2018 04:03PM]:     python2: for python smixer plugin [installed]
170  [05/10/2018 04:03PM]: installing xorg-fonts-encodings...
171  [05/10/2018 04:03PM]: installing xorg-mkfontscale...
172  [05/10/2018 04:03PM]: Creating X fontdir indices... done.
173  [05/10/2018 04:03PM]: installing ttf-google-fonts-typewolf...
174  [05/10/2018 04:03PM]: Optional dependencies for libgnome-keyring
175  [05/10/2018 04:03PM]:     gnome-keyring: key storage service (or use any other service implementing org.freedesktop.secrets)
176  [05/10/2018 04:03PM]: ( 1/11) Updating fontconfig cache...
177  [05/10/2018 04:03PM]: ( 2/11) Probing GDK-Pixbuf loader modules...
178  [05/10/2018 04:03PM]: ( 3/11) Updating GIO module cache...
179  [05/10/2018 04:03PM]: ( 4/11) Probing GTK2 input method modules...
180  [05/10/2018 04:03PM]: ( 5/11) Updating icon theme caches...
181  [05/10/2018 04:03PM]: ( 9/11) Updating the desktop file MIME type cache...
182  [05/10/2018 04:03PM]: (10/11) Updating the MIME type database...
183  [05/10/2018 04:03PM]: (11/11) Updating X fontdir indices...
184  [05/10/2018 04:03PM]: Packages (7) c-ares-1.13.0-1  http-parser-2.8.1-1  libuv-1.20.3-1  node-gyp-3.6.2-1  nodejs-10.1.0-1  semver-5.5.0-1  npm-6.0.1-1
185  [05/10/2018 04:03PM]: Total Download Size:    8.14 MiB
186  [05/10/2018 04:03PM]: Total Installed Size:  52.86 MiB
187  [05/10/2018 04:03PM]: downloading npm-6.0.1-1-any.pkg.tar.xz...
188  [05/10/2018 04:03PM]: Optional dependencies for nodejs
189  [05/10/2018 04:03PM]:     npm: nodejs package manager [pending]
190  [05/10/2018 04:03PM]: (1/1) Arming ConditionNeedsUpdate...
191  [05/10/2018 04:03PM]:   -> Cloning browser-laptop git repo...
192  [05/10/2018 04:03PM]: Cloning into bare repository /pkg/browser-laptop...
193  [05/10/2018 04:03PM]: ==> Validating source files with md5sums...
194  [05/10/2018 04:03PM]:     brave.desktop ... Passed
195  [05/10/2018 04:03PM]:     browser-laptop ... Skipped
196  [05/10/2018 04:03PM]:   -> Creating working copy of browser-laptop git repo...
197  [05/10/2018 04:03PM]: Cloning into browser-laptop...
198  [05/10/2018 04:03PM]: Switched to a new branch makepkg
199  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] metascraper has 1 high vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=metascraper&version=1.0.7 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
200  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] is-my-json-valid has 1 low vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=is-my-json-valid&version=2.16.1 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
201  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] ws has 1 high vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=ws&version=1.1.4 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
202  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] hoek has 1 moderate vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=hoek&version=2.16.3 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
203  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] superagent has 1 low vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=superagent&version=3.5.2 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
204  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] sshpk has 1 high vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=sshpk&version=1.13.1 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
205  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] superagent has 1 low vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=superagent&version=1.8.5 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
206  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] ws has 1 high vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=ws&version=2.3.1 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
207  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] minimatch has 1 high vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=minimatch&version=0.3.0 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
208  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] minimatch has 1 high vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=minimatch&version=0.2.14 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
209  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] debug has 1 low vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=debug&version=2.6.8 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
210  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] ws has 1 high vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=ws&version=3.2.0 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
211  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] lodash has 1 low vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=lodash&version=3.10.1 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
212  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] randomatic has 1 low vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=randomatic&version=1.1.7 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
213  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] debug has 1 low vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=debug&version=2.2.0 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
214  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] deep-extend has 1 low vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=deep-extend&version=0.4.1 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
215  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] minimatch has 1 high vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=minimatch&version=2.0.10 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
216  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] lodash has 1 low vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=lodash&version=4.17.4 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
217  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] moment has 1 low vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=moment&version=2.12.0 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
218  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] https-proxy-agent has 1 high vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=https-proxy-agent&version=1.0.0 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
219  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] deep-extend has 1 low vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=deep-extend&version=0.2.11 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
220  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] http-proxy-agent has 1 high vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=http-proxy-agent&version=1.0.0 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
221  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] debug has 1 low vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=debug&version=2.6.7 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
222  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] moment has 1 low vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=moment&version=2.18.1 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
223  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] mime has 1 moderate vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=mime&version=1.3.4 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
224  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] marked has 1 high vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=marked&version=0.3.6 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
225  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] hoek has 1 moderate vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=hoek&version=4.2.0 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
226  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] growl has 1 critical vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=growl&version=1.9.2 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
227  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] lodash has 1 low vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=lodash&version=1.0.2 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
228  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] deep-extend has 1 low vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=deep-extend&version=0.4.2 - Run `npm i [email protected]latest -g` to upgrade your npm version, and then `npm audit` to get more info.
229  [05/10/2018 04:04PM]: npm WARN notice [SECURITY] lodash has 1 low vulnerability. Go here for more details: https://nodesecurity.io/advisories?search=lodash&version=4.13.1 - Run `npm i [email protected] -g` to upgrade your npm version, and then `npm audit` to get more info.
230  [05/10/2018 04:04PM]: > [email protected] install /pkg/src/browser-laptop/node_modules/dtrace-provider
231  [05/10/2018 04:04PM]: > [email protected] install /pkg/src/browser-laptop/node_modules/sha3
232  [05/10/2018 04:04PM]: make: Entering directory /pkg/src/browser-laptop/node_modules/sha3/build
233  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/sha3/src/addon.o
234  [05/10/2018 04:04PM]: In file included from /pkg/src/.node-gyp/4.5.15/src/node.h:42,
235  [05/10/2018 04:04PM]:                  from ../src/addon.cpp:1:
236  [05/10/2018 04:04PM]: /pkg/src/.node-gyp/4.5.15/deps/v8/include/v8.h: In static member function static void v8::V8::RemoveGCPrologueCallback(v8::GCCallback):
237  [05/10/2018 04:04PM]: /pkg/src/.node-gyp/4.5.15/deps/v8/include/v8.h:10310:53: warning: cast between incompatible function types from v8::GCCallback {aka void (*)(v8::GCType, v8::GCCallbackFlags)} to v8::Isolate::GCCallback {aka void (*)(v8::Isolate*, v8::GCType, v8::GCCallbackFlags)} [-Wcast-function-type]
238  [05/10/2018 04:04PM]:        reinterpret_cast<Isolate::GCCallback>(callback));
239  [05/10/2018 04:04PM]:                                                      ^
240  [05/10/2018 04:04PM]: /pkg/src/.node-gyp/4.5.15/deps/v8/include/v8.h: In static member function static void v8::V8::RemoveGCEpilogueCallback(v8::GCCallback):
241  [05/10/2018 04:04PM]: /pkg/src/.node-gyp/4.5.15/deps/v8/include/v8.h:10317:53: warning: cast between incompatible function types from v8::GCCallback {aka void (*)(v8::GCType, v8::GCCallbackFlags)} to v8::Isolate::GCCallback {aka void (*)(v8::Isolate*, v8::GCType, v8::GCCallbackFlags)} [-Wcast-function-type]
242  [05/10/2018 04:04PM]: In file included from ../../nan/nan.h:192,
243  [05/10/2018 04:04PM]:                  from ../src/addon.cpp:4:
244  [05/10/2018 04:04PM]: ../../nan/nan_maybe_43_inl.h: In function Nan::Maybe<bool> Nan::ForceSet(v8::Local<v8::Object>, v8::Local<v8::Value>, v8::Local<v8::Value>, v8::PropertyAttribute):
245  [05/10/2018 04:04PM]: ../../nan/nan_maybe_43_inl.h:112:73: warning: v8::Maybe<bool> v8::Object::ForceSet(v8::Local<v8::Context>, v8::Local<v8::Value>, v8::Local<v8::Value>, v8::PropertyAttribute) is deprecated: Use CreateDataProperty / DefineOwnProperty [-Wdeprecated-declarations]
246  [05/10/2018 04:04PM]:    return obj->ForceSet(isolate->GetCurrentContext(), key, value, attribs);
247  [05/10/2018 04:04PM]:                                                                          ^
248  [05/10/2018 04:04PM]: In file included from /pkg/src/.node-gyp/4.5.15/deps/v8/include/v8.h:26,
249  [05/10/2018 04:04PM]: /pkg/src/.node-gyp/4.5.15/deps/v8/include/v8.h:3115:29: note: declared here
250  [05/10/2018 04:04PM]:                  Maybe<bool> ForceSet(Local<Context> context, Local<Value> key,
251  [05/10/2018 04:04PM]:                              ^~~~~~~~
252  [05/10/2018 04:04PM]: /pkg/src/.node-gyp/4.5.15/deps/v8/include/v8config.h:318:3: note: in definition of macro V8_DEPRECATED
253  [05/10/2018 04:04PM]:    declarator __attribute__((deprecated(message)))
254  [05/10/2018 04:04PM]: ../../nan/nan.h: In function void Nan::AsyncQueueWorker(Nan::AsyncWorker*):
255  [05/10/2018 04:04PM]: ../../nan/nan.h:1732:62: warning: cast between incompatible function types from void (*)(uv_work_t*) {aka void (*)(uv_work_s*)} to uv_after_work_cb {aka void (*)(uv_work_s*, int)} [-Wcast-function-type]
256  [05/10/2018 04:04PM]:      , reinterpret_cast<uv_after_work_cb>(AsyncExecuteComplete)
257  [05/10/2018 04:04PM]:                                                               ^
258  [05/10/2018 04:04PM]: ../src/addon.cpp: In static member function static Nan::NAN_METHOD_RETURN_TYPE SHA3Hash::New(Nan::NAN_METHOD_ARGS_TYPE):
259  [05/10/2018 04:04PM]: ../src/addon.cpp:49:23: warning: new of type SHA3Hash with extended alignment 32 [-Waligned-new=]
260  [05/10/2018 04:04PM]: ../src/addon.cpp:49:23: note: uses void* operator new(std::size_t), which does not have an alignment parameter
261  [05/10/2018 04:04PM]: ../src/addon.cpp:49:23: note: use -faligned-new to enable C++17 over-aligned new support
262  [05/10/2018 04:04PM]: ../src/addon.cpp:59:58: warning: v8::Local<v8::Object> v8::Function::NewInstance(int, v8::Local<v8::Value>*) const is deprecated: Use maybe version [-Wdeprecated-declarations]
263  [05/10/2018 04:04PM]:     info.GetReturnValue().Set(cons->NewInstance(argc, argv));
264  [05/10/2018 04:04PM]:                                                           ^
265  [05/10/2018 04:04PM]: /pkg/src/.node-gyp/4.5.15/deps/v8/include/v8.h:3844:31: note: declared here
266  [05/10/2018 04:04PM]:                  Local<Object> NewInstance(int argc, Local<Value> argv[]) const);
267  [05/10/2018 04:04PM]:                                ^~~~~~~~~~~
268  [05/10/2018 04:04PM]: ../src/addon.cpp: At global scope:
269  [05/10/2018 04:04PM]: /pkg/src/.node-gyp/4.5.15/src/node.h:448:43: warning: cast between incompatible function types from void (*)(Nan::ADDON_REGISTER_FUNCTION_ARGS_TYPE) {aka void (*)(v8::Local<v8::Object>)} to node::addon_register_func {aka void (*)(v8::Local<v8::Object>, v8::Local<v8::Value>, void*)} [-Wcast-function-type]
270  [05/10/2018 04:04PM]:        (node::addon_register_func) (regfunc),                          \
271  [05/10/2018 04:04PM]:                                            ^
272  [05/10/2018 04:04PM]: /pkg/src/.node-gyp/4.5.15/src/node.h:479:3: note: in expansion of macro NODE_MODULE_X
273  [05/10/2018 04:04PM]:    NODE_MODULE_X(modname, regfunc, NULL, 0)
274  [05/10/2018 04:04PM]: ../src/addon.cpp:164:1: note: in expansion of macro NODE_MODULE
275  [05/10/2018 04:04PM]:  NODE_MODULE(sha3, SHA3Hash::Init)
276  [05/10/2018 04:04PM]: /pkg/src/.node-gyp/4.5.15/deps/v8/include/v8.h: In instantiation of void v8::PersistentBase<T>::SetWeak(P*, typename v8::WeakCallbackInfo<P>::Callback, v8::WeakCallbackType) [with P = node::ObjectWrap; T = v8::Object; typename v8::WeakCallbackInfo<P>::Callback = void (*)(const v8::WeakCallbackInfo<node::ObjectWrap>&)]:
277  [05/10/2018 04:04PM]: /pkg/src/.node-gyp/4.5.15/src/node_object_wrap.h:64:78:   required from here
278  [05/10/2018 04:04PM]: /pkg/src/.node-gyp/4.5.15/deps/v8/include/v8.h:9278:16: warning: cast between incompatible function types from v8::WeakCallbackInfo<node::ObjectWrap>::Callback {aka void (*)(const v8::WeakCallbackInfo<node::ObjectWrap>&)} to Callback {aka void (*)(const v8::WeakCallbackInfo<void>&)} [-Wcast-function-type]
279  [05/10/2018 04:04PM]:                 reinterpret_cast<Callback>(callback), type);
280  [05/10/2018 04:04PM]:                 ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
281  [05/10/2018 04:04PM]: /pkg/src/.node-gyp/4.5.15/deps/v8/include/v8.h: In instantiation of void v8::PersistentBase<T>::SetWeak(P*, typename v8::WeakCallbackInfo<P>::Callback, v8::WeakCallbackType) [with P = Nan::ObjectWrap; T = v8::Object; typename v8::WeakCallbackInfo<P>::Callback = void (*)(const v8::WeakCallbackInfo<Nan::ObjectWrap>&)]:
282  [05/10/2018 04:04PM]: ../../nan/nan_object_wrap.h:66:61:   required from here
283  [05/10/2018 04:04PM]: /pkg/src/.node-gyp/4.5.15/deps/v8/include/v8.h:9278:16: warning: cast between incompatible function types from v8::WeakCallbackInfo<Nan::ObjectWrap>::Callback {aka void (*)(const v8::WeakCallbackInfo<Nan::ObjectWrap>&)} to Callback {aka void (*)(const v8::WeakCallbackInfo<void>&)} [-Wcast-function-type]
284  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/sha3/src/displayIntermediateValues.o
285  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/sha3/src/KeccakF-1600-reference.o
286  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/sha3/src/KeccakNISTInterface.o
287  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/sha3/src/KeccakSponge.o
288  [05/10/2018 04:04PM]:   SOLINK_MODULE(target) Release/obj.target/sha3.node
289  [05/10/2018 04:04PM]: make: Leaving directory /pkg/src/browser-laptop/node_modules/sha3/build
290  [05/10/2018 04:04PM]: > [email protected] install /pkg/src/browser-laptop/node_modules/bufferutil
291  [05/10/2018 04:04PM]: > prebuild-install || node-gyp rebuild
292  [05/10/2018 04:04PM]: /pkg/src/browser-laptop/node_modules/node-abi/index.js:45
293  [05/10/2018 04:04PM]:   throw new Error(Could not detect abi for version  + target +  and runtime  + runtime + .  Updating node-abi might help solve this issue if it is a new release of  + runtime)
294  [05/10/2018 04:04PM]: Error: Could not detect abi for version 4.5.15 and runtime electron.  Updating node-abi might help solve this issue if it is a new release of electron
295  [05/10/2018 04:04PM]:     at getAbi (/pkg/src/browser-laptop/node_modules/node-abi/index.js:45:9)
296  [05/10/2018 04:04PM]:     at module.exports (/pkg/src/browser-laptop/node_modules/prebuild-install/rc.js:57:12)
297  [05/10/2018 04:04PM]:     at Object.<anonymous> (/pkg/src/browser-laptop/node_modules/prebuild-install/bin.js:9:25)
298  [05/10/2018 04:04PM]:     at Module._compile (internal/modules/cjs/loader.js:678:30)
299  [05/10/2018 04:04PM]:     at Object.Module._extensions..js (internal/modules/cjs/loader.js:689:10)
300  [05/10/2018 04:04PM]:     at Module.load (internal/modules/cjs/loader.js:589:32)
301  [05/10/2018 04:04PM]:     at tryModuleLoad (internal/modules/cjs/loader.js:528:12)
302  [05/10/2018 04:04PM]:     at Function.Module._load (internal/modules/cjs/loader.js:520:3)
303  [05/10/2018 04:04PM]:     at Function.Module.runMain (internal/modules/cjs/loader.js:719:10)
304  [05/10/2018 04:04PM]:     at startup (internal/bootstrap/node.js:228:19)
305  [05/10/2018 04:04PM]: make: Entering directory /pkg/src/browser-laptop/node_modules/bufferutil/build
306  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/bufferutil/src/bufferutil.o
307  [05/10/2018 04:04PM]:                  from ../node_modules/nan/nan.h:49,
308  [05/10/2018 04:04PM]:                  from ../src/bufferutil.cc:7:
309  [05/10/2018 04:04PM]: In file included from ../node_modules/nan/nan.h:192,
310  [05/10/2018 04:04PM]: ../node_modules/nan/nan_maybe_43_inl.h: In function Nan::Maybe<bool> Nan::ForceSet(v8::Local<v8::Object>, v8::Local<v8::Value>, v8::Local<v8::Value>, v8::PropertyAttribute):
311  [05/10/2018 04:04PM]: ../node_modules/nan/nan_maybe_43_inl.h:112:73: warning: v8::Maybe<bool> v8::Object::ForceSet(v8::Local<v8::Context>, v8::Local<v8::Value>, v8::Local<v8::Value>, v8::PropertyAttribute) is deprecated: Use CreateDataProperty / DefineOwnProperty [-Wdeprecated-declarations]
312  [05/10/2018 04:04PM]: ../node_modules/nan/nan.h: In function void Nan::AsyncQueueWorker(Nan::AsyncWorker*):
313  [05/10/2018 04:04PM]: ../node_modules/nan/nan.h:1732:62: warning: cast between incompatible function types from void (*)(uv_work_t*) {aka void (*)(uv_work_s*)} to uv_after_work_cb {aka void (*)(uv_work_s*, int)} [-Wcast-function-type]
314  [05/10/2018 04:04PM]: ../src/bufferutil.cc: At global scope:
315  [05/10/2018 04:04PM]: ../src/bufferutil.cc:113:1: note: in expansion of macro NODE_MODULE
316  [05/10/2018 04:04PM]:  NODE_MODULE(bufferutil, init)
317  [05/10/2018 04:04PM]: ../node_modules/nan/nan_object_wrap.h:66:61:   required from here
318  [05/10/2018 04:04PM]:   SOLINK_MODULE(target) Release/obj.target/bufferutil.node
319  [05/10/2018 04:04PM]:   COPY Release/bufferutil.node
320  [05/10/2018 04:04PM]: make: Leaving directory /pkg/src/browser-laptop/node_modules/bufferutil/build
321  [05/10/2018 04:04PM]: > [email protected] install /pkg/src/browser-laptop/node_modules/leveldown
322  [05/10/2018 04:04PM]: make: Entering directory /pkg/src/browser-laptop/node_modules/leveldown/build
323  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/db/builder.o
324  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/db/db_impl.o
325  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/db/db_iter.o
326  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/db/filename.o
327  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/db/dbformat.o
328  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/db/log_reader.o
329  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/db/log_writer.o
330  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/db/memtable.o
331  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/db/repair.o
332  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/db/table_cache.o
333  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/db/version_edit.o
334  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/db/version_set.o
335  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/db/write_batch.o
336  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/helpers/memenv/memenv.o
337  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/port/port_posix_sse.o
338  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/table/block.o
339  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/table/block_builder.o
340  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/table/filter_block.o
341  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/table/format.o
342  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/table/iterator.o
343  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/table/merger.o
344  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/table/table.o
345  [05/10/2018 04:04PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/table/table_builder.o
346  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/table/two_level_iterator.o
347  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/util/arena.o
348  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/util/bloom.o
349  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/util/cache.o
350  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/util/coding.o
351  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/util/comparator.o
352  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/util/crc32c.o
353  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/util/env.o
354  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/util/filter_policy.o
355  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/util/hash.o
356  [05/10/2018 04:05PM]: ../deps/leveldb/leveldb-1.20/util/hash.cc: In function uint32_t leveldb::Hash(const char*, size_t, uint32_t):
357  [05/10/2018 04:05PM]: ../deps/leveldb/leveldb-1.20/util/hash.cc:37:9: warning: this statement may fall through [-Wimplicit-fallthrough=]
358  [05/10/2018 04:05PM]:        h += static_cast<unsigned char>(data[2]) << 16;
359  [05/10/2018 04:05PM]:        ~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
360  [05/10/2018 04:05PM]: ../deps/leveldb/leveldb-1.20/util/hash.cc:39:5: note: here
361  [05/10/2018 04:05PM]: ../deps/leveldb/leveldb-1.20/util/hash.cc:40:9: warning: this statement may fall through [-Wimplicit-fallthrough=]
362  [05/10/2018 04:05PM]:        h += static_cast<unsigned char>(data[1]) << 8;
363  [05/10/2018 04:05PM]: ../deps/leveldb/leveldb-1.20/util/hash.cc:42:5: note: here
364  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/util/logging.o
365  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/util/options.o
366  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/util/status.o
367  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/port/port_posix.o
368  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/util/env_posix.o
369  [05/10/2018 04:05PM]:   AR(target) Release/obj.target/deps/leveldb/leveldb.a
370  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/snappy/deps/snappy/snappy-1.1.4/snappy-sinksource.o
371  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/snappy/deps/snappy/snappy-1.1.4/snappy-stubs-internal.o
372  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/snappy/deps/snappy/snappy-1.1.4/snappy.o
373  [05/10/2018 04:05PM]:   AR(target) Release/obj.target/deps/snappy/snappy.a
374  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/leveldown/src/batch.o
375  [05/10/2018 04:05PM]:                  from ../src/batch.cc:1:
376  [05/10/2018 04:05PM]:                  from ../src/batch.cc:3:
377  [05/10/2018 04:05PM]: In file included from ../src/batch.cc:5:
378  [05/10/2018 04:05PM]: ../src/database.h: At global scope:
379  [05/10/2018 04:05PM]: ../src/database.h:86:7: warning: unnecessary parentheses in declaration of pendingCloseWorker [-Wparentheses]
380  [05/10/2018 04:05PM]:    void(*pendingCloseWorker);
381  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/leveldown/src/batch_async.o
382  [05/10/2018 04:05PM]:                  from ../src/batch.h:5,
383  [05/10/2018 04:05PM]:                  from ../src/batch_async.cc:8:
384  [05/10/2018 04:05PM]:                  from ../src/database.h:16,
385  [05/10/2018 04:05PM]:                  from ../src/batch.h:9,
386  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/leveldown/src/database.o
387  [05/10/2018 04:05PM]:                  from ../src/database.cc:6:
388  [05/10/2018 04:05PM]:                  from ../src/leveldown.h:11,
389  [05/10/2018 04:05PM]:                  from ../src/database.cc:12:
390  [05/10/2018 04:05PM]: In file included from ../src/database.cc:13:
391  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/leveldown/src/database_async.o
392  [05/10/2018 04:05PM]:                  from ../src/database_async.cc:6:
393  [05/10/2018 04:05PM]:                  from ../src/database_async.cc:12:
394  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/leveldown/src/iterator.o
395  [05/10/2018 04:05PM]:                  from ../src/iterator.cc:6:
396  [05/10/2018 04:05PM]:                  from ../src/iterator.cc:9:
397  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/leveldown/src/iterator_async.o
398  [05/10/2018 04:05PM]:                  from ../src/iterator_async.cc:6:
399  [05/10/2018 04:05PM]:                  from ../src/iterator_async.cc:9:
400  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/leveldown/src/leveldown.o
401  [05/10/2018 04:05PM]:                  from ../src/leveldown.cc:6:
402  [05/10/2018 04:05PM]:                  from ../src/leveldown.cc:8:
403  [05/10/2018 04:05PM]: In file included from ../src/leveldown.cc:9:
404  [05/10/2018 04:05PM]: /pkg/src/.node-gyp/4.5.15/src/node.h:448:43: warning: cast between incompatible function types from void (*)(v8::Local<v8::Object>) to node::addon_register_func {aka void (*)(v8::Local<v8::Object>, v8::Local<v8::Value>, void*)} [-Wcast-function-type]
405  [05/10/2018 04:05PM]: ../src/leveldown.cc:73:1: note: in expansion of macro NODE_MODULE
406  [05/10/2018 04:05PM]:  NODE_MODULE(leveldown, Init)
407  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/leveldown/src/leveldown_async.o
408  [05/10/2018 04:05PM]:                  from ../src/leveldown.h:8,
409  [05/10/2018 04:05PM]:                  from ../src/leveldown_async.cc:8:
410  [05/10/2018 04:05PM]: In file included from ../src/async.h:11,
411  [05/10/2018 04:05PM]:                  from ../src/leveldown_async.h:11,
412  [05/10/2018 04:05PM]:                  from ../src/leveldown_async.cc:9:
413  [05/10/2018 04:05PM]:   SOLINK_MODULE(target) Release/obj.target/leveldown.node
414  [05/10/2018 04:05PM]:   COPY Release/leveldown.node
415  [05/10/2018 04:05PM]: make: Leaving directory /pkg/src/browser-laptop/node_modules/leveldown/build
416  [05/10/2018 04:05PM]: > [email protected] install /pkg/src/browser-laptop/node_modules/prova-lib/node_modules/secp256k1
417  [05/10/2018 04:05PM]: > prebuild-install || node-gyp rebuild || echo Secp256k1 bindings compilation fail. Pure JS implementation will be used.
418  [05/10/2018 04:05PM]: make: Entering directory /pkg/src/browser-laptop/node_modules/prova-lib/node_modules/secp256k1/build
419  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/secp256k1/src/addon.o
420  [05/10/2018 04:05PM]:                  from ../src/addon.cc:1:
421  [05/10/2018 04:05PM]: In file included from ../../../../nan/nan.h:192,
422  [05/10/2018 04:05PM]:                  from ../src/addon.cc:2:
423  [05/10/2018 04:05PM]: ../../../../nan/nan_maybe_43_inl.h: In function Nan::Maybe<bool> Nan::ForceSet(v8::Local<v8::Object>, v8::Local<v8::Value>, v8::Local<v8::Value>, v8::PropertyAttribute):
424  [05/10/2018 04:05PM]: ../../../../nan/nan_maybe_43_inl.h:112:73: warning: v8::Maybe<bool> v8::Object::ForceSet(v8::Local<v8::Context>, v8::Local<v8::Value>, v8::Local<v8::Value>, v8::PropertyAttribute) is deprecated: Use CreateDataProperty / DefineOwnProperty [-Wdeprecated-declarations]
425  [05/10/2018 04:05PM]: ../../../../nan/nan.h: In function void Nan::AsyncQueueWorker(Nan::AsyncWorker*):
426  [05/10/2018 04:05PM]: ../../../../nan/nan.h:1732:62: warning: cast between incompatible function types from void (*)(uv_work_t*) {aka void (*)(uv_work_s*)} to uv_after_work_cb {aka void (*)(uv_work_s*, int)} [-Wcast-function-type]
427  [05/10/2018 04:05PM]: ../src/addon.cc: At global scope:
428  [05/10/2018 04:05PM]: ../src/addon.cc:48:1: note: in expansion of macro NODE_MODULE
429  [05/10/2018 04:05PM]: ../../../../nan/nan_object_wrap.h:66:61:   required from here
430  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/secp256k1/src/privatekey.o
431  [05/10/2018 04:05PM]:                  from ../src/privatekey.cc:1:
432  [05/10/2018 04:05PM]:                  from ../src/privatekey.cc:2:
433  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/secp256k1/src/publickey.o
434  [05/10/2018 04:05PM]:                  from ../src/publickey.cc:2:
435  [05/10/2018 04:05PM]:                  from ../src/publickey.cc:3:
436  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/secp256k1/src/signature.o
437  [05/10/2018 04:05PM]:                  from ../src/signature.cc:1:
438  [05/10/2018 04:05PM]:                  from ../src/signature.cc:2:
439  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/secp256k1/src/ecdsa.o
440  [05/10/2018 04:05PM]:                  from ../src/ecdsa.cc:1:
441  [05/10/2018 04:05PM]:                  from ../src/ecdsa.cc:2:
442  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/secp256k1/src/ecdh.o
443  [05/10/2018 04:05PM]:                  from ../src/ecdh.cc:1:
444  [05/10/2018 04:05PM]:                  from ../src/ecdh.cc:2:
445  [05/10/2018 04:05PM]:   CC(target) Release/obj.target/secp256k1/src/secp256k1-src/src/secp256k1.o
446  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c: In function secp256k1_ec_pubkey_parse:
447  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:22:8: warning: nonnull argument pubkey compared to NULL [-Wnonnull-compare]
448  [05/10/2018 04:05PM]:      if (EXPECT(!(cond), 0)) { \
449  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:154:5: note: in expansion of macro ARG_CHECK
450  [05/10/2018 04:05PM]:      ARG_CHECK(pubkey != NULL);
451  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:22:8: warning: nonnull argument input compared to NULL [-Wnonnull-compare]
452  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:156:5: note: in expansion of macro ARG_CHECK
453  [05/10/2018 04:05PM]:      ARG_CHECK(input != NULL);
454  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c: In function secp256k1_ec_pubkey_serialize:
455  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:22:8: warning: nonnull argument output compared to NULL [-Wnonnull-compare]
456  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:175:5: note: in expansion of macro ARG_CHECK
457  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:22:8: warning: nonnull argument outputlen compared to NULL [-Wnonnull-compare]
458  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:171:5: note: in expansion of macro ARG_CHECK
459  [05/10/2018 04:05PM]:      ARG_CHECK(outputlen != NULL);
460  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:177:5: note: in expansion of macro ARG_CHECK
461  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c: In function secp256k1_ecdsa_signature_parse_der:
462  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:22:8: warning: nonnull argument sig compared to NULL [-Wnonnull-compare]
463  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:216:5: note: in expansion of macro ARG_CHECK
464  [05/10/2018 04:05PM]:      ARG_CHECK(sig != NULL);
465  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:217:5: note: in expansion of macro ARG_CHECK
466  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c: In function secp256k1_ecdsa_signature_parse_compact:
467  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:234:5: note: in expansion of macro ARG_CHECK
468  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:22:8: warning: nonnull argument input64 compared to NULL [-Wnonnull-compare]
469  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:235:5: note: in expansion of macro ARG_CHECK
470  [05/10/2018 04:05PM]:      ARG_CHECK(input64 != NULL);
471  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c: In function secp256k1_ecdsa_signature_serialize_der:
472  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:253:5: note: in expansion of macro ARG_CHECK
473  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:254:5: note: in expansion of macro ARG_CHECK
474  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:255:5: note: in expansion of macro ARG_CHECK
475  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c: In function secp256k1_ecdsa_signature_serialize_compact:
476  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:22:8: warning: nonnull argument output64 compared to NULL [-Wnonnull-compare]
477  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:265:5: note: in expansion of macro ARG_CHECK
478  [05/10/2018 04:05PM]:      ARG_CHECK(output64 != NULL);
479  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:266:5: note: in expansion of macro ARG_CHECK
480  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c: In function secp256k1_ecdsa_signature_normalize:
481  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:22:8: warning: nonnull argument sigin compared to NULL [-Wnonnull-compare]
482  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:279:5: note: in expansion of macro ARG_CHECK
483  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c: In function secp256k1_ecdsa_verify:
484  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:300:5: note: in expansion of macro ARG_CHECK
485  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:22:8: warning: nonnull argument msg32 compared to NULL [-Wnonnull-compare]
486  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:299:5: note: in expansion of macro ARG_CHECK
487  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:301:5: note: in expansion of macro ARG_CHECK
488  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c: In function secp256k1_ecdsa_sign:
489  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:22:8: warning: nonnull argument signature compared to NULL [-Wnonnull-compare]
490  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:353:5: note: in expansion of macro ARG_CHECK
491  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:352:5: note: in expansion of macro ARG_CHECK
492  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:22:8: warning: nonnull argument seckey compared to NULL [-Wnonnull-compare]
493  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:354:5: note: in expansion of macro ARG_CHECK
494  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c: In function secp256k1_ec_seckey_verify:
495  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:396:5: note: in expansion of macro ARG_CHECK
496  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c: In function secp256k1_ec_pubkey_create:
497  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:411:5: note: in expansion of macro ARG_CHECK
498  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:414:5: note: in expansion of macro ARG_CHECK
499  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c: In function secp256k1_ec_privkey_negate:
500  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:430:5: note: in expansion of macro ARG_CHECK
501  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c: In function secp256k1_ec_pubkey_negate:
502  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:443:5: note: in expansion of macro ARG_CHECK
503  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c: In function secp256k1_ec_privkey_tweak_add:
504  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:460:5: note: in expansion of macro ARG_CHECK
505  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:22:8: warning: nonnull argument tweak compared to NULL [-Wnonnull-compare]
506  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:461:5: note: in expansion of macro ARG_CHECK
507  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c: In function secp256k1_ec_pubkey_tweak_add:
508  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:484:5: note: in expansion of macro ARG_CHECK
509  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:485:5: note: in expansion of macro ARG_CHECK
510  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c: In function secp256k1_ec_privkey_tweak_mul:
511  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:507:5: note: in expansion of macro ARG_CHECK
512  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:508:5: note: in expansion of macro ARG_CHECK
513  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c: In function secp256k1_ec_pubkey_tweak_mul:
514  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:530:5: note: in expansion of macro ARG_CHECK
515  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:531:5: note: in expansion of macro ARG_CHECK
516  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c: In function secp256k1_ec_pubkey_combine:
517  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:22:8: warning: nonnull argument pubnonce compared to NULL [-Wnonnull-compare]
518  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:559:5: note: in expansion of macro ARG_CHECK
519  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:22:8: warning: nonnull argument pubnonces compared to NULL [-Wnonnull-compare]
520  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:562:5: note: in expansion of macro ARG_CHECK
521  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c: In function secp256k1_ecdsa_recoverable_signature_parse_compact:
522  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/modules/recovery/main_impl.h:44:5: note: in expansion of macro ARG_CHECK
523  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/modules/recovery/main_impl.h:45:5: note: in expansion of macro ARG_CHECK
524  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c: In function secp256k1_ecdsa_recoverable_signature_serialize_compact:
525  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/modules/recovery/main_impl.h:64:5: note: in expansion of macro ARG_CHECK
526  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:22:8: warning: nonnull argument recid compared to NULL [-Wnonnull-compare]
527  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/modules/recovery/main_impl.h:66:5: note: in expansion of macro ARG_CHECK
528  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/modules/recovery/main_impl.h:65:5: note: in expansion of macro ARG_CHECK
529  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c: In function secp256k1_ecdsa_recoverable_signature_convert:
530  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/modules/recovery/main_impl.h:79:5: note: in expansion of macro ARG_CHECK
531  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/modules/recovery/main_impl.h:80:5: note: in expansion of macro ARG_CHECK
532  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c: In function secp256k1_ecdsa_sign_recoverable:
533  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/modules/recovery/main_impl.h:132:5: note: in expansion of macro ARG_CHECK
534  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/modules/recovery/main_impl.h:131:5: note: in expansion of macro ARG_CHECK
535  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/modules/recovery/main_impl.h:133:5: note: in expansion of macro ARG_CHECK
536  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c: In function secp256k1_ecdsa_recover:
537  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/modules/recovery/main_impl.h:179:5: note: in expansion of macro ARG_CHECK
538  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/modules/recovery/main_impl.h:178:5: note: in expansion of macro ARG_CHECK
539  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/modules/recovery/main_impl.h:177:5: note: in expansion of macro ARG_CHECK
540  [05/10/2018 04:05PM]:   CC(target) Release/obj.target/secp256k1/src/secp256k1-src/contrib/lax_der_parsing.o
541  [05/10/2018 04:05PM]:   CC(target) Release/obj.target/secp256k1/src/secp256k1-src/contrib/lax_der_privatekey_parsing.o
542  [05/10/2018 04:05PM]:   SOLINK_MODULE(target) Release/obj.target/secp256k1.node
543  [05/10/2018 04:05PM]: make: Leaving directory /pkg/src/browser-laptop/node_modules/prova-lib/node_modules/secp256k1/build
544  [05/10/2018 04:05PM]: > [email protected] install /pkg/src/browser-laptop/node_modules/secp256k1
545  [05/10/2018 04:05PM]: make: Entering directory /pkg/src/browser-laptop/node_modules/secp256k1/build
546  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:433:5: note: in expansion of macro ARG_CHECK
547  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:434:5: note: in expansion of macro ARG_CHECK
548  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:457:5: note: in expansion of macro ARG_CHECK
549  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:458:5: note: in expansion of macro ARG_CHECK
550  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:480:5: note: in expansion of macro ARG_CHECK
551  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:481:5: note: in expansion of macro ARG_CHECK
552  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:503:5: note: in expansion of macro ARG_CHECK
553  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:504:5: note: in expansion of macro ARG_CHECK
554  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:532:5: note: in expansion of macro ARG_CHECK
555  [05/10/2018 04:05PM]: ../src/secp256k1-src/src/secp256k1.c:535:5: note: in expansion of macro ARG_CHECK
556  [05/10/2018 04:05PM]: make: Leaving directory /pkg/src/browser-laptop/node_modules/secp256k1/build
557  [05/10/2018 04:05PM]: > [email protected]:brave/electron-chromedriver#772ace180da97768478ce9683b871449c621205a install /pkg/src/browser-laptop/node_modules/spectron/node_modules/electron-chromedriver
558  [05/10/2018 04:05PM]: > node ./download-chromedriver.js
559  [05/10/2018 04:05PM]: > [email protected] install /pkg/src/browser-laptop/node_modules/electron-chromedriver
560  [05/10/2018 04:05PM]: (node:4624) ExperimentalWarning: The fs.promises API is experimental
561  [05/10/2018 04:05PM]: > [email protected] install /pkg/src/browser-laptop/node_modules/keytar
562  [05/10/2018 04:05PM]: make: Entering directory /pkg/src/browser-laptop/node_modules/keytar/build
563  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/keytar/src/main.o
564  [05/10/2018 04:05PM]:                  from ../node_modules/nan/nan.h:47,
565  [05/10/2018 04:05PM]:                  from ../src/main.cc:1:
566  [05/10/2018 04:05PM]: ../node_modules/nan/nan.h:1712:62: warning: cast between incompatible function types from void (*)(uv_work_t*) {aka void (*)(uv_work_s*)} to uv_after_work_cb {aka void (*)(uv_work_s*, int)} [-Wcast-function-type]
567  [05/10/2018 04:05PM]: ../src/main.cc: At global scope:
568  [05/10/2018 04:05PM]: /pkg/src/.node-gyp/4.5.15/src/node.h:448:43: warning: cast between incompatible function types from void (*)(v8::Handle<v8::Object>) {aka void (*)(v8::Local<v8::Object>)} to node::addon_register_func {aka void (*)(v8::Local<v8::Object>, v8::Local<v8::Value>, void*)} [-Wcast-function-type]
569  [05/10/2018 04:05PM]: ../src/main.cc:60:1: note: in expansion of macro NODE_MODULE
570  [05/10/2018 04:05PM]:  NODE_MODULE(keytar, Init)
571  [05/10/2018 04:05PM]:   CXX(target) Release/obj.target/keytar/src/keytar_posix.o
572  [05/10/2018 04:05PM]:   SOLINK_MODULE(target) Release/obj.target/keytar.node
573  [05/10/2018 04:05PM]:   COPY Release/keytar.node
574  [05/10/2018 04:05PM]: make: Leaving directory /pkg/src/browser-laptop/node_modules/keytar/build
575  [05/10/2018 04:05PM]: > [email protected] install /pkg/src/browser-laptop/node_modules/nsp/node_modules/git-validate
576  [05/10/2018 04:05PM]: (node:2390) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 SIGINT listeners added. Use emitter.setMaxListeners() to increase limit
577  [05/10/2018 04:05PM]: > [email protected]:brave/pre-commit#67aef1db3066f298a25e930c06a8c9f2b19f2a3e install /pkg/src/browser-laptop/node_modules/pre-commit
578  [05/10/2018 04:05PM]: pre-commit: Detected an existing git pre-commit hook
579  [05/10/2018 04:05PM]: pre-commit: Old pre-commit hook backuped to pre-commit.old
580  [05/10/2018 04:05PM]: > [email protected] install /pkg/src/browser-laptop/node_modules/pre-push
581  [05/10/2018 04:05PM]: pre-push: Detected an existing git pre-push hook
582  [05/10/2018 04:05PM]: pre-push: Old pre-push hook backuped to pre-push.old
583  [05/10/2018 04:05PM]: > [email protected] postinstall /pkg/src/browser-laptop/node_modules/bat-publisher/node_modules/tldjs
584  [05/10/2018 04:05PM]: > node ./bin/postinstall.js
585  [05/10/2018 04:05PM]: > [email protected] postinstall /pkg/src/browser-laptop/node_modules/spawn-sync
586  [05/10/2018 04:05PM]: > [email protected]:brave/electron-prebuilt#e65e72f4bc7a8e7de160667f3eb3c2b22e3e395e postinstall /pkg/src/browser-laptop/node_modules/electron-prebuilt
587  [05/10/2018 04:05PM]: Downloading brave-v4.5.15-linux-x64.zip
588  [05/10/2018 04:05PM]: [>                                            ] 0.0% (0 B/s)
589  [05/10/2018 04:05PM]: Downloading brave-v4.5.15-linux-x64.zip
590  [05/10/2018 04:05PM]: [>                                            ] 0.0% of 54.92 MB (0 B/s)
591  [05/10/2018 04:05PM]: [>                                            ] 1.3% of 54.92 MB (729.62 kB/s)
592  [05/10/2018 04:05PM]: [=>                                           ] 6.1% of 54.92 MB (3.36 MB/s)
593  [05/10/2018 04:05PM]: [====>                                        ] 12.9% of 54.92 MB (5.68 MB/s)
594  [05/10/2018 04:05PM]: [========>                                    ] 20.7% of 54.92 MB (7.59 MB/s)
595  [05/10/2018 04:05PM]: [===========>                                 ] 28.7% of 54.92 MB (9.01 MB/s)
596  [05/10/2018 04:05PM]: [================>                            ] 38.5% of 54.92 MB (10.58 MB/s)
597  [05/10/2018 04:05PM]: [======================>                      ] 53.3% of 54.92 MB (13.01 MB/s)
598  [05/10/2018 04:05PM]: [================================>            ] 74.6% of 54.92 MB (16.38 MB/s)
599  [05/10/2018 04:05PM]: [============================================>] 100.0% of 54.92 MB (18.31 MB/s)
600  [05/10/2018 04:05PM]: > [email protected] postinstall /pkg/src/browser-laptop/node_modules/flow-bin
601  [05/10/2018 04:05PM]: node[4750]: ../src/node_contextify.cc:628:static void node::contextify::ContextifyScript::New(const v8::FunctionCallbackInfo<v8::Value>&): Assertion `args[1]->IsString() failed.
602  [05/10/2018 04:05PM]:  3: node::contextify::ContextifyScript::New(v8::FunctionCallbackInfo<v8::Value> const&) [node]
603  [05/10/2018 04:05PM]:  4: v8::internal::FunctionCallbackArguments::Call(v8::internal::CallHandlerInfo*) [node]
604  [05/10/2018 04:05PM]: /pkg/PKGBUILD: line 41:  2390 Aborted                 (core dumped) PYTHON=/usr/bin/python2 HOME=${srcdir} npm install
605  [05/10/2018 04:05PM]: ==> ERROR: A failure occurred in build().
606  [05/10/2018 04:05PM]: rm: cannot remove **.pkg.**: No such file or directory
607  [05/10/2018 04:05PM]: [\^/\^/^\^/^\^/\^/\^/^\^/^\^/]  BUILD FAILED  [\^/\^/^\^/^\^/\^/\^/^\^/^\^/]